Watershed Sciences 4930 & 6920
ADVANCED GIS

WEEK SIX – Lecture

ANALYSES COMBINING VECTOR AND RASTER DATA

Joe Wheaton
HOUSEKEEPING

• Questions?
WHAT DOES ‘COMBINING’ MEAN?

We’ve worked with raster & vector data throughout the semester...

• Does it mean preserving data type but using both to:
  – Convey information?
  – Perform analyses?

• Does it mean conversion?
  – e.g. Raster -> Vector
  – e.g. Vector -> Raster

Image from: http://www.indiana.edu/~gisci/courses/g338/lectures/introduction_vector.html
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Rater & Vector Data Types
   I. Types of Conversions
   II. Classification
   III. Interpolation
   IV. Analysis

IV. Summary & Reminders
REVIEW – DISCRETE vs. CONTINUOUS

- Spatially Continuous Fields
  - Only rasters can represent continuous fields

- Spatially Discrete Objects
  - Vector data (points, polygons, polylines) are always spatially discrete
  - Raster data can be discrete (only when represented as an integer)

Infrared Photo from USGS:
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Rater & Vector Data Types
   I. Types of Conversions
   II. Classification
   III. Interpolation
   IV. Analysis

IV. Summary & Reminders
USING VECTOR & RASTER DATA SIMULTANEOUSLY

- Overlaying information for better context...
  - LAYERS!
A GEOLOGY MAP: JUST GEOLOGY...
A GEOLOGY MAP: MORE VECTOR DATA

A Portion of the Geologic Map of the Logan 30' x 60' Quadrangle

Data from Utah Geological Survey: http://geology.utah.gov/
A GEOLOGY MAP: ADD DRG USGS BASE

A Portion of the Geologic Map of the Logan 30' x 60' Quadrangle

A GEOLOGY MAP: ADD HILLSHADE RASTER

A Portion of the Geologic Map of the Logan 30' x 60' Quadrangle

Projection: UTM Zone 12
Units: Meters
Datum: NAD 1983
Spheroid: Clarke 1866

Data from Utah Geological Survey 2006
Miscellaneous Publication MP06-8 DM
Mapping by J.H. Dover

Data from Utah Geological Survey: http://geology.utah.gov/
Topographic Data from: http://gis.utah.gov/
CONTEX OF AN AERIAL PHOTO...

- These vector data are draped (elevated) according to a raster DEM
- Combining the data with an orthophoto helps set the context
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Rater & Vector Data Types
   I. Types of Conversions
   II. Classification
   III. Interpolation
   IV. Analysis

IV. Summary & Reminders
PERFORMING ANALYSES

Most examples are of using vector data to analyze or sample raster data

- **Extraction**: Using *points* to extract raster values at specific locations on a raster

- **Profiling**: Using *polylines* to extract raster values along a route

- **Spatial Masking**: Using *polygons* to perform a segregated raster analysis

- **Clipping**: Using *polygons* to trim a dataset down...
EXTRACTION

- Use points showing spawning locations to extract water depth values from the raster.
SAMPLING

- Extraction for multiple layers
PROFILING

Extract raster values (DEM elevations) along a polyline at every vertex...

5 m DEM Data from: [http://gis.utah.gov/](http://gis.utah.gov/)
From Wheaton (2008):
http://www.joewheaton.org.uk/Research/Projects/PhDThesis.asp
CLIPPING

We just want the DEM for our study Watershed (Wood Camp Hollow)

Use a polygon to clip a raster dataset

GIS Data from: http://gis.utah.gov/
LEAST-COST PATH

• A cost raster identifies the cost of traveling through each cell.

So steep and forested is expensive; flat & urban cheap
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Raster & Vector Data Types
   I. Types of Conversions
      II. Classification
      III. Interpolation
      IV. Analysis

IV. Summary & Reminders
TYPES OF CONVERSIONS

Vector to Raster
- Point to Raster
- Polyline to Raster
- Polygon to Raster

Raster to Vector
- Raster to Point
- Raster to Polyline
- Raster to Polygon
• Various ways to convert points to a raster
• When multiple points are in a cell, it's based on combination of most frequent & priority
• When points are sparse, just the cells with a point get a value, the rest are no data

• Choice of raster resolution critical!
POLYLINE TO RASTER

GIS Data from: http://gis.utah.gov
POLYGON TO RASTER

• A common method of going from one discrete representation to another

• Applications:
  – Classifications
  – Boundaries
  – Masks
  – Boolean Logic

WHY BOTHER CONVERTING TO RASTER?

• Raster Math (allowing global cell-by-cell calculations using raster calculator)
• Rasters are easy to export and many spatial models are raster based
• There are a plethora of raster-based analyses available
RASTER TO POINT

- Extracts the raster value and assigns it to a point located at the center of each grid cell
- Useful if you need to have continuous data discretized to finite number of points (e.g. a uniform stakeout)
**RASTER TO POLYLINE: DRAINAGE NETWORK DEFINED**

- Connect cells above threshold
- Stream Order

We’ll talk about this in next Tuesday’s Lecture

Image from *Multi-Watershed Delineation Tool Manual*
© 2006, Chinnayakanahalli – Utah State University
RASTER TO POLYGON

- Only works for discrete (integer) or classified rasters
  - Can’t convert DEM
  - But a reclassified DEM into elevation bands can be...
  - Watershed delineations can also be converted

Images from FME:
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Raster & Vector Data Types
   I. Types of Conversions
      II. Classification
      III. Interpolation
      IV. Analysis

IV. Summary & Reminders
CLASSIFICATION TENDS TO BE RASTER -> VECTOR

- If manual, we call this digitizing

A special case of raster -> polygon
IMAGE CLASSIFICATION

- Buildings
- Streets
- Sidewalks
- Landscaping
- Water
- Vegetation

Primarily raster-based classification of continuous surfaces into discrete integer surfaces; then converted to vectors.

Follow Up Courses

At Utah State University

There are too many courses to list, which employ GIS skills that you might learn in WATS 4930/6920 or an equivalent. However, here are a few follow ups that you might find useful:

<table>
<thead>
<tr>
<th>Course</th>
<th>Title</th>
<th>Cr</th>
<th>Term</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>SEE 3225</td>
<td>Engineering Surveying</td>
<td>3</td>
<td>Sp</td>
<td>Fundamentals of geometric surveying</td>
</tr>
<tr>
<td>WATS 5999</td>
<td>Remote Sensing of Land Surfaces</td>
<td>3</td>
<td>Sp</td>
<td>Covers principles of remote sensing</td>
</tr>
<tr>
<td>WILD 6720</td>
<td>Applied Remote Sensing</td>
<td>3</td>
<td>Fs</td>
<td>Learn image classification using imagery</td>
</tr>
<tr>
<td>WILD 6720</td>
<td>GIS Programming with Python</td>
<td>3</td>
<td>Sp</td>
<td>This is a great follow up that focuses on</td>
</tr>
</tbody>
</table>

Image from Selim Aksoy:
http://www.cs.bilkent.edu.tr/~saksoy/research.html
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Rater & Vector Data Types
   I. Types of Conversions
   II. Classification
   III. Interpolation
   IV. Analysis

IV. Summary & Reminders
INTERPOLATION...

- Many types of interpolation
- Based on assumption of spatial correlation

We’ll talk about this in next Thursday’s Lecture (week from today)
A Triangular Irregular Network (TIN) is the simplest and most common interpolation technique for building surfaces with irregularly spaced elevation data (McCullagh, 1981).

3D Surface Visualization of TIN

What is an appropriate grid resolution?

- Should be fine enough to resolve ______
- Should not be too much finer than the resolution of available data
- Some $f$(topographic complexity, point density)

BUT...
THE N-SQUARED PROBLEM

- Doubling the resolution squares the number of cells!
- Arbitrary increases in resolution lead to larger file sizes and longer computational time...

<table>
<thead>
<tr>
<th>Resolution (m)</th>
<th>Dimensions</th>
<th>Total # of Cells</th>
<th>Bytes (Double 64 bit)</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>2 x 2</td>
<td>4</td>
<td>32</td>
</tr>
<tr>
<td>50</td>
<td>4 x 4</td>
<td>16</td>
<td>128</td>
</tr>
<tr>
<td>25</td>
<td>8 x 8</td>
<td>64</td>
<td>512</td>
</tr>
<tr>
<td>20</td>
<td>10 x 10</td>
<td>100</td>
<td>800</td>
</tr>
<tr>
<td>10</td>
<td>20 x 20</td>
<td>400</td>
<td>3200</td>
</tr>
<tr>
<td>5</td>
<td>40 x 40</td>
<td>1600</td>
<td>12,800</td>
</tr>
</tbody>
</table>
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Raster & Vector Data Types
   I. Types of Conversions
   II. Classification
   III. Interpolation

IV. Analysis

IV. Summary & Reminders
ANALYSIS

• Conversions, classifications and interpolation have all been shown to be useful forms of analysis

• Are there any other analyses that result in a conversion between vector and raster, but that are not direct conversions, classifications or interpolation?
  • Density
    • Kernel Density
    • Line Density
    • Point Density
A unique type of moving window analysis that produces a density raster from point vector data.
ANOTHER DENSITY EXAMPLE...

- Bonneville Cutthroat Trout

- Can we identify hot spots where these fish are found in high densities?
PIT TAG LOCATIONS

- Mobile antennae surveys
- PIT tags plotted from Lat/Long coordinates
- What’s wrong with these?

From Ryan Lokteff
THE NEAR TOOL

- Analysis Tools > Proximity > Near
- Location must be checked
Points “snapped” to the stream by plotting the new coordinates from the Near tool.
The Point Density Tool creates a raster based on characteristics of an input point feature.
This doesn’t do much good without better symbology or a reclassification.
Density units odd... so just used 10 equal interval breaks and turned zeros into NoData
Cutthroat and Brown Trout Utilization Hotspots in Temple Fork

Legend
Cutthroat Density Value
- High: 10
- Low: 1

Brown Density Value
- High: 10
- Low: 1
WHAT IF I WANTED TO GO BACK TO LINE?

• I want to attribute the line...
• So instead of density being points per area, they’d be *Points per unit* or *Points per length of line*...

Data from Ryan Steve Bennett (ELR)
FLUVIAL AUDIT... POOL INVENTORY

• How many pools are in each reach?
• OR What reach are the pools in?
• Isn’t this just a vector data question?
WHAT I WANT IS...

- A new column that has how many pools (i.e. points) in each reach (just counts)
- Then I can use field calculator to divide by reach length...
ACTUALLY...

- Deciding exactly what you want/need to address a question is the challenge...
- Lots of ways to get there...

To get what reach pools are in:
- Ran a Buffer Analysis on stream polyline to create a polygon buffer with Flat End type of 10 m around stream reach
- Did a Spatial Join to bring the column from the reach file over to the point features (pools in this example)
TODAY’S PLAN

I. Review

II. Using Vector & Raster Data Simultaneously to:
   I. Convey Information
   II. Perform Analyses

III. Converting Between Rater & Vector Data Types
   I. Types of Conversions
   II. Classification
   III. Interpolation
   IV. Analysis

IV. Summary & Reminders
TODAY’S SUMMARY

Analysis combining raster and vector data can:

• preserve data type but use both to:
  – Convey information more clearly
  – Perform analyses otherwise not possible

• mean converting between
  – Raster -> Vector
  – Vector -> Raster
REMEMBER…

• No lecture on Tuesday
• Look online for a Raster Analysis Podcast (on Tuesday) instead
• Still have labs…
• Next Thursday – DEM Lecture
READING FOR NEXT THURSDAY

READING for Thursday, March 21st
posted a minute ago by Joe Wheaton

Read Chapter 11 on Terrain Analysis from Bolstad (2008).